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Welcome to Time Stamp, a product of Syntap Software!

Time Stamp is an open-source donationware program that you can use to easily track time spent
on a project. It enables you to time how long you spend on a task, including features that let you
take "slack time" for a phone call or break. Times for various tasks can be linked to an hourly
charge rate for accurate billing.

About Time Stamp

Since its first public release in April 1997, Time Stamp grown into a very popular task timing tool.
I hope you enjoy it!
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License Info

Redistribution

The GNU General Public License

Feel free to give copies of Time Stamp to anyone who may like to use it. Time Stamp is released
under the GNU General Public License (GPL). In a nutshell, this means that the source code to
Time Stamp is freely available, modifiable, and redistributable as long as the terms of the GPL
are followed. If you are publishing Time Stamp on a CD-ROM, magazine disk, software club, or
any kind of media where money is exchanged (even for zero profit), please e-mail me the biblio-
graphic information for the particular issue at the address provided in the About box.

The text of the GPL can be read here, as well as at http://www.fsf.org.

Source Code

The Source Code for Time Stamp is freely available under the GNU GPL. It can be downloaded
from the Time Stamp web site. If you received a modified version of Time Stamp, you should al-
so have received information on how to obtain the source code for the modified version, as well
as a statement covering your rights to use and modify the software under the GPL. If you did not
receive information on how to obtain the source code for Time Stamp or any program based on
the GPL’d source code of Time Stamp contact me.
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Disclaimer
THIS DISCLAIMER SUPPLEMENTS THE GNU GENERAL PUBLIC LICENSE.

THE TIME STAMP SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY
KIND, EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WAR-
RANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.

IN NO EVENT SHALL WILLIAM ROUCK OR SYNTAP SOFTWARE BE LIABLE FOR ANY SPE-
CIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DA-
MAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER
OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF LIABILITY,
ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFT-
WARE.

The GNU General Public License

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.

59 Temple Place - Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but chan-
ging it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it.
By contrast, the GNU General Public License is intended to guarantee your freedom to share and
change free software--to make sure the software is free for all its users. This General Public Li-
cense applies to most of the Free Software Foundation's software and to any other program who-
se authors commit to using it. (Some other Free Software Foundation software is covered by the
GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Li-
censes are designed to make sure that you have the freedom to distribute copies of free software
(and charge for this service if you wish), that you receive source code or can get it if you want it,
that you can change the software or use pieces of it in new free programs; and that you know you
can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or
to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if
you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give
the recipients all the rights that you have. You must make sure that they, too, receive or can get
the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license
which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands
that there is no warranty for this free software. If the software is modified by someone else and
passed on, we want its recipients to know that what they have is not the original, so that any
problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the
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danger that redistributors of a free program will individually obtain patent licenses, in effect ma-
king the program proprietary. To prevent this, we have made it clear that any patent must be li-
censed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copy-
right holder saying it may be distributed under the terms of this General Public License. The
"Program”, below, refers to any such program or work, and a "work based on the Program"
means either the Program or any derivative work under copyright law: that is to say, a work con-
taining the Program or a portion of it, either verbatim or with modifications and/or translated into
another language. (Hereinafter, translation is included without limitation in the term
"modification”.) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they
are outside its scope. The act of running the Program is not restricted, and the output from the

Program is covered only if its contents constitute a work based on the Program (independent of
having been made by running the Program). Whether that is true depends on what the Program
does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in
any medium, provided that you conspicuously and appropriately publish on each copy an appro-
priate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this Li-
cense and to the absence of any warranty; and give any other recipients of the Program a copy
of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer
warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work
based on the Program, and copy and distribute such modifications or work under the terms of
Section 1 above, provided that you also meet all of these conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the
files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or
is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third
parties under the terms of this License.

C) If the modified program normally reads commands interactively when run, you must cause
it, when started running for such interactive use in the most ordinary way, to print or display an
announcement including an appropriate copyright notice and a notice that there is no warranty (or
else, saying that you provide a warranty) and that users may redistribute the program under these
conditions, and telling the user how to view a copy of this License. (Exception: if the Program it-
self is interactive but does not normally print such an announcement, your work based on the
Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work
are not derived from the Program, and can be reasonably considered independent and separate
works in themselves, then this License, and its terms, do not apply to those sections when you
distribute them as separate works. But when you distribute the same sections as part of a whole
which is a work based on the Program, the distribution of the whole must be on the terms of this
License, whose permissions for other licensees extend to the entire whole, and thus to each and
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every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely
by you; rather, the intent is to exercise the right to control the distribution of derivative or collective
works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or
with a work based on the Program) on a volume of a storage or distribution medium does not
bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object
code or executable form under the terms of Sections 1 and 2 above provided that you also do
one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which
must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for
software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a
charge no more than your cost of physically performing source distribution, a complete machine-
readable copy of the corresponding source code, to be distributed under the terms of Sections 1
and 2 above on a medium customarily used for software interchange; or,

C) Accompany it with the information you received as to the offer to distribute corresponding
source code. (This alternative is allowed only for noncommercial distribution and only if you recei-
ved the program in object code or executable form with such an offer, in accord with Subsection b
above.)

The source code for a work means the preferred form of the work for making modifications to it.
For an executable work, complete source code means all the source code for all modules it con-
tains, plus any associated interface definition files, plus the scripts used to control compilation
and installation of the executable. However, as a special exception, the source code distributed
need not include anything that is normally distributed (in either source or binary form) with the ma-
jor components (compiler, kernel, and so on) of the operating system on which the executable
runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated
place, then offering equivalent access to copy the source code from the same place counts as
distribution of the source code, even though third parties are not compelled to copy the source
along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided
under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program
is void, and will automatically terminate your rights under this License. However, parties who have
received copies, or rights, from you under this License will not have their licenses terminated so
long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing el-
se grants you permission to modify or distribute the Program or its derivative works. These ac-
tions are prohibited by law if you do not accept this License. Therefore, by modifying or distribu-
ting the Program (or any work based on the Program), you indicate your acceptance of this Licen-
se to do so, and all its terms and conditions for copying, distributing or modifying the Program or
works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient au-
tomatically receives a license from the original licensor to copy, distribute or modify the Program
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subject to these terms and conditions. You may not impose any further restrictions on the reci-
pients' exercise of the rights granted herein. You are not responsible for enforcing compliance by
third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other
reason (not limited to patent issues), conditions are imposed on you (whether by court order, ag-
reement or otherwise) that contradict the conditions of this License, they do not excuse you from
the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obliga-
tions under this License and any other pertinent obligations, then as a consequence you may not
distribute the Program at all. For example, if a patent license would not permit royalty-free redistri-
bution of the Program by all those who receive copies directly or indirectly through you, then the
only way you could satisfy both it and this License would be to refrain entirely from distribution of
the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance,
the balance of the section is intended to apply and the section as a whole is intended to apply in
other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right
claims or to contest validity of any such claims; this section has the sole purpose of protecting the
integrity of the free software distribution system, which is implemented by public license practices.
Many people have made generous contributions to the wide range of software distributed through
that system in reliance on consistent application of that system; it is up to the author/donor to de-
cide if he or she is willing to distribute software through any other system and a licensee cannot
impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the
rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents
or by copyrighted interfaces, the original copyright holder who places the Program under this Li-
cense may add an explicit geographical distribution limitation excluding those countries, so that
distribution is permitted only in or among countries not thus excluded. In such case, this License
incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public
License from time to time. Such new versions will be similar in spirit to the present version, but
may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number
of this License which applies to it and "any later version”, you have the option of following the
terms and conditions either of that version or of any later version published by the Free Software
Foundation. If the Program does not specify a version number of this License, you may choose
any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution
conditions are different, write to the author to ask for permission. For software which is copyrigh-
ted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make
exceptions for this. Our decision will be guided by the two goals of preserving the free status of
all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRES-
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SED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MER-
CHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO
THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVI-
CING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR RE-
DISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARI-
SING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMI-
TED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAI-
NED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH
ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

Registration and Donations

Donations to encourage future development and to help pay for the upkeep of the supporting
web site are welcome. A donation is not required for your free use of Time Stamp, however |
make enhancement decisions based on the number of requests | get for a particular enhance-
ment from users who have donated.

There are two easy ways to support Time Stamp. The first (and the preferred way) is to purchase
a copy of my CD by going to www.SynapseTapestry.com. A portion of each CD sale will also be
donated to worldwide disaster relief on behalf of the users of Time Stamp.

The second is a monetary donation using the PayPal "Donate" links found on the Syntap Softwa-
re home page and the Time Stamp Download page.

Maintenance of Time Stamp

Even though Time Stamp is donationware, | believe that if others use it then | ought to do my best
to enhance (and fix) it to make it a better tool for myself and for the user community. | have been
extremely fortunate to have many people e-mail with suggestions and bug reports, and | believe
the utility has improved as a result.

If you find a bug or would like to see an enhancement, please contact me via the e-mail address
given in the About box or via http://www.syntap.com .
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Version History

Version 3.20, 9-6-2006
New Features

Incremental time

Added shortcut key sequences in Notes dialog and in Notes in task edit. CTRL-A for Se-
lect All, CTRL-ENTER to hit dialog OK button, and ESC to hit dialog Cancel button.

Ability to quickly chain end time of tasks to start times of subsequent tasks, as well as star
times of tasks to end times of preceding tasks

Version 3.12, 7-30-2003
Miscellaneous bug fix release.

Version 3.11, 3-03-2003
New Features

There is a new GUI Options Preference setting that lets you customize the font size of the
text in the Outlook Bar buttons.

When exporting ASCII text, elements in mutli-line Notes fields are now separated by a se-
micolon to keep the entire Notes field within the tab delimitation.

The source code is now included in the distribution under the "src" directory.
Bug Fixes

Hopefully fixed the "Recent Files" Outlook bar area to properly display buttons for recently
opened and saved files.

Reports should now pay attention to font type and size preferences.

Fixed bug where column sort corrupted data when a manual edit of start or end times oc-
curred before project was last saved.

Other column sorting bug fixes.

Version 3.10, 06-11-2002
New Features

A new projects bar allows the user to quickly switch between projects

Columns are now sortable by clicking on the column header

Timer Key shortcuts (F9-F12) can be disabled

Modifying of task stop time by clicking on stop time column for a given task has been re-
moved
Bug Fixes

Changed startup screen location from Desktop Center to Screen Center (for multiple-dis-
play desktop users)

Version 3.03, 05-05-2001
New Features

Time Stamp is now Copylefted under the GNU General Public License. See License info
in the Help document for what this means.

In the Notes dialog, ALT-O and ALT-C will hit the OK button and Cancel button, respecti-

vely.

Toolbar is now hideable in normal and reduced mode.
Bug Fixes

Dialog boxes should now appear correctly when "Always On Top" option is turned on.

Combo box in Notes screens adjusted to not allow user input other than a Quicken-style
lookup.

Total Work Cost no longer prints in report when user preference for no printing of cost da-
ta is selected.

Reduced Mode now works properly if Time Stamp was maximized when user hits reduced
mode.
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Version 3.02, 11-30-2000
New Features

Grid will now take 750 entries (was 500). The reason | just don’'t make this ten million or
something is because | want to keep the memory footprint as small as possible.

Added a warning message when user has reached bottom of grid.
Bug Fixes

Printed report text color now defaults to Black... it previously pulled in the color of Wind-
ows text in the Display control panel, which caused a problem on B&W printers when users speci-
fied white text.

Corrected a problem in Auto-Save where the saving only occurred once.

Version 3.01, 03-15-2000
New Features

Renamed all of the "Log" commands to "Project" commands to make all menu commands
consistent.
Bug Fixes

Existing Project Title does not go away when a new project is created.

Open/Save dialogs now note version 3.0 files along with 2.5 files. The file formats are the
same... | wanted to prevent possible confusion.

Version 3.00, 03-07-2000

New Features

Resizable and hideable grid columns.

An XML export module so you can port your Time Stamp data to other XML-enabled appli-
cations.

The interface is now resizable, and your layouts are now saved to preferences.

Grid color preferences for background and text.

Tray icon can be set to "blink" while timing.

You can add "end notes," which are tacked on to the bottom of the Time Stamp report.
Both general default and project-specific end notes can be saved.

A default Note List Builder. These are added to Notes fields via a drop-down list in the
Notes dialog. This gives you a list of "template” Notes whenever you add one to a task.

Upper limit on number of tasks increased to 500.

Added preferences to show/hide work time, slack time, and work cost columns in the grid.

Added preference to keep task button visible when Task Tray option is activated.

Added preference for flashing icon in task tray while timing is active.

Added Print preferences for displaying rate information.

You can now use the Enter key within Notes fields.

Current development is being conducted under Windows 2000, so Time Stamp will work
and be tested with the full gamut of 32-bit Windows operating systems.
Bug Fixes

The "A4"-size printing problem.

Time Stamp did not consider deleting a row a "change" to the project and therefore did not
bring up the "Save Now" dialog when exiting.

Version 2.50, 02-25-99

Added preference and coding to start screen saver when Slack time is started. Note that if
you have AutoSave on the slack timer will restart after each save, causing the screen saver to
kick in.

Re-formatted Preferences dialog.
: Added preferences for default tray icon click behavior... restore the main form or start/stop
timer.

: Added preference for not printing Slack information in report

Task Bar item is now hidden when Tray Icon option is in force.

Added pie chart work/slack representation of current task to Task Edit screen.
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: Added "Append File" (add tasks from another file to current task list) and "Save As" func-
tions.
: In report, the Notes column will now wrap if text is too long.
(drum roll) Notes column expanded from 55 to 255 characters!
: New file type ".SA2" now saves expanded Notes field and works with new ".TS2" file to
store a Project Title and the last default hourly rate used for that particular file.

Added ability to specify a "project name". This replaces the "Time Stamp Report" report ti-
tle if it is specified.
Bug Fixes

Fixed bug where user specified a textual month (i.e. 09-Sep-98) for the Regional Setting's
ShortDateFormat. The internal conversion of this text to a calculable date would barf on the text.
Now the exception is caught and the conversion process (to improve rounding appearances) is
foregone.

Fixed bug where resetting grid in Reduced Mode did not reset the "big" time panel caption.
Times in memory still valid but this panel didn't reflect that.

Fixed some more International date/time settings issues.

Disabled the AutoSave process if no rows are in the grid.

Fixed a Y2K issue in the Edit Task screen.

Version 2.00, 05-05-98

Option for automatically saving log files at user-specified time intervals added to Preferen-
ces dialog.

Added ability to double-click on a saved Time Stamp file and have Time Stamp automati-
cally load it on start up.

Changed time formats to display a leading zero for one-digit results for minutes, seconds,
etc. Makes things line up a little better.

Added a Status Bar below grid to provide user messages.

Increased maximum number of rows in grid from 150 to 300.

Enabled ability to maximize the Time Stamp interface screen.

Added an MRU (Most Recently Updated) list to file menu. When a file is saved, its file na-
me will appear there for quick reloading.

In task bar, the time now appears before the text 'TIMING'. When things get tight in the
task bar, you should be able to see more of the time than before.

Task rows are now selectable via a column of selection buttons.

Added full task editing functions. Start Time, End Time, Work Time, Slack Time, Hourly
Rate, and Notes can all be edited from the Edit Selected Task menu item or toolbar button. Now
that column of Hourly Rates in the printed report will be worth something!

Added preference item for starting the timer immediately upon startup.

Disabled the Delete Row command while in reduced mode. The selected row is invisible
while in Reduced Mode and the wrong row could be deleted.

Added preference item for a default directory for loading / saving files.

Fixed bug where the Reduced Mode button would not stay down when Reduced Mode
was selected from the Menu or via F5.

Added a "Print Preview" menu item, making the Print button do a direct print instead of
showing a Print Preview screen.

Optimized so that all of the above could be added while taking up less system memory.

Version 1.30f, 03-28-98
Fixed a bug in the display of summary time information in the top half of the screen and in
the summary info of the printed report. All the time and money calculations are correct, but when
the summary times are over 24 hours, the time chops that off and the hours are displayed as
(true hours - 24 hours). A total of 30 hours, 30 minutes would look like "6:30:00" on the panel.
Added setup program host site info to the About box.

Version 1.30e, 02-16-98
When Close command is called (either by menu selection or Windows Close button, Time
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Stamp will now check to see if timers are active. If they are, they will be stopped before you are
asked to save the file.

Version 1.30d, 02-11-98

Tray icon click behavior modified to not stop the timer if the slack timer is running. If slack
timer is running, clicking on the tray icon will now turn it off and put Time Stamp back into regular
timing mode.

Titles of buttons and their corresponding menu items synchronized.

Time Stamp should now look normal when launched on a system with "large fonts" selec-

ted.
Time totals and dollar amounts are now right-justified in the grid so they line up correctly.

Version 1.30c, 02-10-98
Fixed bug introduced in 1.30b that erased the entire grid's data when a row was deleted.
Moving through grid with arrow keys should now synchronize correctly with what Time
Stamp thinks the currently selected row is.
Minimize and Restore commands are now available from the tray icon menu.

Version 1.30b, 02-03-98
Fixed bug where some information from a previous project was not cleared when a "Clear
Grid" command was issued.

Version 1.30a, 01-28-98
No feature changes, just fixed a minor bug in how the "Save Log" command knows to not
display the "File Save" dialog.

Version 1.30, 01-26-98

Tray Icon now has a menu attached to it to handle major timing functions.

Tray Icon is now color-coded based on current timing action.

Hitting "Save Log" will now directly write a currently loaded (as opposed to new) file wi-
thout annoying you with the "File Save" dialog.

Selecting "Decimal” output for summary data in ASCII file export now sets this option for
the printed report.

User is now asked if he/she would like to save any changes before Windows shuts down.

Version 1.20, 12-29-97

Fixed a bug where Total Time returns ridiculous values under some conditions.

Removed support for importing old beta data file format.

Fixed bug where user had ability to set the end-time in a currently-timing row.

Menu item (and keyboard shortcut) for 'Stop Timer' is now deactivated when no timing is
occurring.

Added Tray Icon (set this in the Preferences dialog). It only starts/stops the clock for now,
but it will do more in future releases.

Version 1.13, 12-11-97

Disabled "Delete Row" command while timing is in progress. Caused problems with cur-
rent locations of in-progress rows in the grid.

Made a few visual enhancements to grid, including title column and ellipses (...) for notes
field when text is too wide for column.

Added a warning to the "change end time" dialog box concerning the recalculation of the
"work time" total on a row that has had its timer stopped and re-started.

Version 1.12, 12-01-97

Added hyperlink to Time Stamp home page in About Box

Improved Save File dialog boxes to automatically prompt with the filename of the latest
opened file
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Added option in Preferences to output summary info as real numbers in the ASCII delimi-
ted file export, i.e. an hour and a half would be expressed as ‘1.5'.

Version 1.11, 11-26-97
Enabled date formats to pull from Windows settings, instead of assuming US formats.
Sorry international users! | ignored you again!

Version 1.10, 11-25-97

Added an "Export to Delimited ASCII" function so grid data could be transferred over to a
database file or Excel. The outputted file is TAB-delimited.

Changed keyboard shortcut for File|Exit from ‘e’ to ‘X' to be consistent with everyone else.

Added an "Always on Top" feature, which can be toggled from a command in the Tools
menu.

File|Open and File|Save dialogs how remember where they were last.

Added "Reduced Mode" workspace option for screen real-estate savings. Added Prefe-
rences option to always start in this mode.

Added "F1" shortcut for Help.

| received complaints that times did not appear to be adding up correctly when subtracting
slack from the total, or adding up all work times and not getting what Time Stamp reported as the
total. This is due to the program calculating times in increments of 0.000001 days. A second is
0.0000116 of a day, so the program is calculating time at a precision of roughly an eighth of a se-
cond. The display only shows time to the second, so the fraction is hidden. It is not however hid-
den from calculations, so the total should be correct. | have attempted in this release to round the
recorded time to the nearest second and hopefully the differences will now be minimized. | have
not changed precision for cost calculations, so total costs may not be exactly equal to a hand-
summing of the individual task costs that appear as rounded to the nearest penny (but kept in
memory as fractional pennies). If anyone is charging by the second let me know and I'll change
it... that's about all such a fix would be good for.

Version 1.01, 11-07-97
Fixed bug that incorrectly reports total time differences in some cases. Some extra variab-
le initialization fixed the problem.

Version 1.00, 11-02-97

Added Preferences dialog under File Menu

Added Help file

Implemented automatic loading of last file saved (toggled in Preferences dialog)

Menu commands for license info and version history now invoke Help file sections instead
of displaying distributed text files
: When timing is active, task bar item now reflects timing status. When Time Stamp is mini-
mized the user can now get status by passing mouse over task bar item

Removed left and right frames from printed report... lines did not always line up very well
on dot matrix bi-directional printouts

Expanded data file. Notes column now takes 55 characters instead of 25. Time Stamp
will import most of the old data files but | have found a couple of old ones that result in an error.
PLEASE PRINT OLD FILES in case this happens to you. E-mail me with the exact file size (in
bytes) of the offending file and we’ll see if we can get it properly loaded again.

Version 0.96, 10-16-97

Clicking on a Notes field properly brings up the current contents of the field.

Row deletion command added. Two notes:

Arrow keys appear to select the current row but they do not. This will be fixed but be awa-
re for now that the program considers the "current row" to be either last row clicked with the mou-
se or the first row in the grid (if you haven't clicked anywhere yet)

The tendency may be to click in the 'START' column to select the row for deletion. Unfor-
tunately, this starts the timer again for that row. I'll find a way to decrease confusion there, but for
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now try to keep the mouse clicks in the 'TOTAL,' 'SLACK," or 'WORK' columns for row selection.
While a row is timing, a "time elapsed" counter appears next to the word 'TIMING' in the
'STOP' column.

Version 0.95, 10-09-97
Implemented "continued" time elements by allowing user to click on a current row's
'START' column.

Version 0.94, 09-01-97
Added professional-looking time report and print preview

Version 0.93, 04-21-97
Adjusted column widths so main form could fit on a 640x480 screen

Version 0.92, 04-18-97

: Added function key shortcuts for timers
Added "Save changed file" safeguards
Limited NOTE entry to 25 characters
Added Version History menu item (w/error handling)
Added License Info menu item (w/error handing)
Changed slack timer button glyph

Version 0.91, 04-17-97
Added note field editing
Added ability to edit End Time (w/error detection)
Added timing status panel

Version 0.90, 04-16-97
Added printing

Version 0.50, 04-15-97 - First limited beta release
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Timer Functions

Task timing in Time Stamp is done with the following functions:

Start Timer : This command starts the timer for a task and is the way you create a task.
You can start the timer by using any of the following means:

Using the "Start Timer" command in the Timers menu

Pressing the F9 key

Clicking in the colored Timing Status box when timing is stopped

Clicking on the "Start" column on any existing row (re-starts the timer for that row)

Right-clicking on the Time Stamp Tray Icon (if enabled) and selecting "Start Timer" from
the popup menu

Left-clicking on the Time Stamp Tray Icon (if enabled)

Stop Timer: This command stops the timer for a task. You can stop the timer by using any
of the following means:

Using the "Stop Timer" command in the Timers menu

Pressing the F10 key

Clicking in the colored Timing Status box when timer is running

Clicking on the "Start" column on any existing row (stops the timer for that row)

Right-clicking on the Time Stamp Tray Icon (if enabled) and selecting "Stop Timer" from
the popup menu

Left-clicking on the Time Stamp Tray Icon (if enabled)

Start/Stop Slack Timers: Slack timers are used for tracking non-working breaks within a gi-
ven task (phone call, bathroom, distractions, etc.). You can use slack timers by using any of the
following means:

Using the "Start/Stop Slack Timers" command in the Timers menu

Pressing the F11 key (start slack) or the F12 key (stop slack)

Using the "Start/Stop Slack Timers" commands via the Time Stamp Tray Icon (if enabled)
Hourly Charge Rates
The Hourly Rate used to calculate task costs can be set by the following means:

Select "Set Hourly Charge Rate" in the Tools menu

Click in the Hourly Rate box in the upper summary area

Set the task's hourly rate via the "Edit Selected Task" in the Edit menu (or by pressing
Control-E)

Note: The currently displayed hourly rate is the hourly rate that will be used for a new timed row.
This enables you to track different costs for different tasks.

- Page 16 -



TimeStamp - Help-Manual Vers. 3.21, 2006

Editing Task Data

Any information associated with a timed task can be edited. Select the task you wish to edit by
clicking on the Selection Column button to the left of the given row. Select "Edit Selected Task"
from the Edit menu or press the "Edit Selected Task" speed button in the toolbar.

You will see a screen that allows you to edit Start Time, End Time, Work Time, Slack Time, Hour-
ly Rate, and Notes.

Adding Notes to Tasks

You can add a notation to a task one of two ways.

The first is to click in the Notes column corresponding to the task you wish to annotate. You will
see a box in which you may type your notation. Clicking in the Notes column will also allow you to
edit existing annotations.

The second is to use Edit Selected Task in the Edit menu. The Notes field is available for editing
there.Use the Auto-fill drop-down list to append your Notes field with an established Note you ha-
ve defined in the Tools -> Create Default Notes List command.For convenience, pressing ALT-O
will hit the "OK" button, and pressing ALT-C will hit the "Cancel" button.

From time to time you may need to restart timers, delete tasks, or change task data. To specify
which row you intend to modify, press the small button in the leftmost column corresponding to
the task row (this column is referred to as the Task Selection Column in this Help File). The color
of the button should change to Red to alert you to the currently selected row.

Deleting Tasks

You may delete a timed task row by clicking on the row's corresponding Selection Column button
and selecting "Delete Selected Task" from the Edit menu (or pressing Control-Delete). You may
alternatively use the "X" button in the application toolbar.

Sorting Tasks

Your task list can be sorted by Start Time, Stop Time, Work Time, Slack Time, Total Time, Work
Cost, or Notes. Simply click in the gray title area at the top of a given column and Time Stamp
will sort the list based on that column.

Opening and Saving Files

Use the "Open Log File" and "Save Log File" commands in the File menu to retrieve previous task
records and save current logs. You may also utilize the toolbar buttons for these.

You may also load previously-saved files by clicking on a filename listed under the "Exit" com-
mand in the File menu. File names are placed here whenever you save a Time Stamp data file.

The "Append Log File" command may be used to join files. For example, to add "File A" to the

- Page 17 -



TimeStamp - Help-Manual Vers. 3.21, 2006

end of "File B", load "File A" into Time Stamp, choose "Append Log File" and navigate to "File B."
The result will be a combination of the two. You may save "File A" to save the combined file, or
used the "Save As" command to save the new log with a different file name.

Project Bar

The Project Bar allows you to quickly switch back and forth between projects files in your default
save location. When Time Stamp loads, the Project Bar is loaded with buttons for each Time
Stamp file you have stored in the File -> Preferences -> File Options -> Default Directory setting.
Also, when you save a file during a session, a button for it is placed in the "Recent Projects"” area
of the Projects Bar.

You can show/hide the Project Bar by pressing the show/hide projects bar icon in the toolbar. If
you don't really need the Projects Bar, you can disable it by unchecking the "Show Project Bar
when Time Stamp is Loaded" option in the File -> Preferences -> GUI Options area.

Exporting Task Data

You can import the data seen in the grid to another program (such as Microsoft Excel) by using
the "export" commands in the File menu.

Export to Delimited ASCII
This will write the current grid contents into a TAB-delimited text file.
An option in File|Preferences allows you to set the export to express summary time info in

decimal format. For example, an hour and a half would be exported as ‘1.5’ with this option and
'01:30:00’ without it.

Export to XML
This will write the current grid contents to an Extensible Markup Language (XML ) file. The
Data Type Dictionary (DTD) file for Time Stamp data can be found in the XML directory, under the
directory where you installed Time Stamp (default is "C:\Program Files\Time Stamp\XML"
If you have never used or had a need for XML and want to see what this file looks like,

place the "timestamp.dtd" file and an exported XML Time Stamp log into a directory, then open
your XML file in Internet Explorer.

Printing Time Stamp Reports

Select "Print" from the File menu to print a Time Stamp report.
Select "Print Setup” from the File menu to set various printer settings.

Select "Print Preview" from the File menu to see what the printed report will look like before you
print it.

There are several ways to customize your output under the File -> Preferences dialog. These inc-
lude printing end notes, page numbers, and project titles.
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Miscellaneous Tools

Time Stamp includes a few tools to make timing a task as obtrusive or unobtrusive as you cho-
ose. Under the Tools menu, there are a number of options below the Hourly Rate command:

Work in Reduced Mode : Reduces the working area of Time Stamp. New tasks still popu-
late the grid when timers are started and stopped.

Set This Project’s Report End Notes: sets the End Notes for the currently-opened project.
Set Default End Notes: sets the End Notes for all new Time Stamp data files.

Create Default Notes List: you can use this dialog to create default Notes field values.
Whatever you enter for these will appear in a drop-down list wherever you are able to enter Notes
for a task (Task Edit screen, clicking on Notes column in grid, etc).

Set Project Title: The Time Stamp report displays the title "Time Stamp Report" by default.
If you assign a Project Title, the report header is changed to that text.

Always on Top : Keeps Time Stamp on top of other desktop windows. You may still use
other programs but you will always see Time Stamp out in front. It is recommended that you only
toggle this option while working in reduced mode.

Link Selected Task Start Time to Previous Task End Time: This allows you to chain tasks
to other tasks above and below the selected task.

Preferences

User preferences for Time Stamp program behavior can be set from this command. Select
"Preferences" from the File menu to invoke the preferences dialog.

The following preferences are available:

GUI Options

Always start in Reduced Mode

Use decimal format for time summary values in ASCII export and printed report
Show the Project Bar when Time Stamp is loaded

Display the Time Stamp Tray Icon and options for icon functionality
Hide the Task Tray button

Start Timing immediately when Time Stamp is launched

Start Screen Saver when Slack Timing starts

Show timer progress in tray item, task bar button, and grid

Flash Task and Tray Item colors while timing

Disable the timer key shortcuts

Adjust the font size of the Project button bar text

File Options

Automatically Open Last Saved Log

Enable Auto-Save (with a time interval in minutes)

Specify a default directory to use for opening and saving task files
Set new filenames to the Project Title
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Print Options

Report font and size

Print Slack time, rate information

Print Project Title instead of "Time Stamp Report" at top of printout
Print File Name at top of report

Print End Notes

Print Page Numbers

Specify use of 24/12 hour time formats

Print only the Task Start Dates

Color Options
Grid row colors

Other Options
Show Slack Time, Work Time, and Work Cost

Time Rounding options

*k% EN D *k%

- Page 20 -



